Minimum Requirements

Fixed the API level

Android

  • The minimum API level supported by the Hyper SDK is API 21, Android 5.0 (Lollipop) , which allows you to reach more than approximately 90% of all Android devices on the market.
  • Java and Kotlin are both supported. The SDK provides Java interfaces, thus the examples are given in Java, but can be converted to Kotlin seamlessly if required.
  • The Hyper SDK supports AndroidX , but it is not a requirement. You can still use the support library.

👍

NOTE

For all SDK permissions and Proguard rules and FAQs regarding minimum SDK required, please refer to the FAQ section:
https://developer.juspay.in/v2.0/docs/faqs

iOS

  • The Hyper SDK for iOS supports iOS 10.0 or higher.
  • Only simulators running iOS 10.0 or higher are supported.
  • Certain api’s are not supported on simulators so using an iOS device is recommended.
  • Swift and Objective-C both are supported . The SDK provides Objective-c interfaces but easily interoperability in swift. Examples are provided in both Objective-c and Swift.

What’s Next
Did this page help you?